[pgn_compat]
error: